Descent BB

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

   Descent BB Forum Index > Forum Support and Feedback > Ummm JBOMB Post new topic   Reply to topic
View previous topic :: View next topic  
Author Message
AlphaDoG
porn 'n beans




PostPosted: Thu Sep 04, 2008 3:29 am View user's profile Reply with quote Send private message

Clicking the banner does NOT take you to the main page. Just thought you'd like to know.
Bunyip
DBB Staff




PostPosted: Thu Sep 04, 2008 5:43 am View user's profile Reply with quote Send private message

Yeah someone broke flash - it's not Jbomb's fault!

_________________
BELIEVE NOTHING, no matter where you read it, or who has said it,
not even if I have said it, unless it agrees with your own reason
and your own common sense. - GAUTAMA BUDDHA
AceCombat
SpongeBob




PostPosted: Thu Sep 04, 2008 10:08 pm View user's profile Reply with quote Send private message

works now

_________________
A United States Marine, is the last son-ova-bitch you ever want to piss off!!
When it has to be absolutely destroyed and eradicated of any and all enemy forces..... CALL THE MARINES!!!
JBOMB
DBB Cadet




PostPosted: Fri Sep 05, 2008 12:37 am View user's profile Reply with quote Send private message

Let me read some on the matter and get back to you guys. Smile
JBOMB
DBB Cadet




PostPosted: Fri Sep 05, 2008 12:57 am View user's profile Reply with quote Send private message

ok...im pretty sure the easiest fix is to specify AllowScriptAccess="always" in the HTML embed code for the logo:

this code we currently roll:
Code:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/ cabs/flash/swflash.cab#version=6,0,40,0"
width="430" height="91"
id="mymoviename">
<param name="movie"
value="http://descentbb.com/flash/dbb_logo.swf" />
<param name="quality" value="high" />
<param name="bgcolor" value="#ffffff" />
<embed src="http://descentbb.com/flash/dbb_logo.swf" quality="high" bgcolor="#ffffff"
width="430" height="91"
name="mymoviename" align="" type="application/x-shockwave-flash"
pluginspage="http://www.macromedia.com/go/getflashplayer">

</embed>
</object>


gets changed to:

Code:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/ cabs/flash/swflash.cab#version=6,0,40,0"
width="430" height="91"
id="mymoviename">
<param name="movie"
value="http://descentbb.com/flash/dbb_logo.swf" />
<param name="quality" value="high" />
<param name="bgcolor" value="#ffffff" />
<embed src="http://descentbb.com/flash/dbb_logo.swf" allowScriptAccess="always" quality="high" bgcolor="#ffffff"
width="430" height="91"
name="mymoviename" align="" type="application/x-shockwave-flash"
pluginspage="http://www.macromedia.com/go/getflashplayer">

</embed>
</object>


with the addition of allowScriptAccess="always" in the src embed area of that should solve this problem by telling the html page that this bit of flash is "trusted".

I dont know where this code goes in the php so...ROOK?..PUN?...can you please try this and see if it doesnt break the sht Smile
Pun
DBB Admin




PostPosted: Fri Sep 05, 2008 1:26 am View user's profile Reply with quote Send private message

I'll take a peek.
AlphaDoG
porn 'n beans




PostPosted: Fri Sep 05, 2008 4:33 am View user's profile Reply with quote Send private message

AceCombat wrote:
works now




Are you sure? It still don't work for me.
Bunyip
DBB Staff




PostPosted: Fri Sep 05, 2008 5:17 am View user's profile Reply with quote Send private message

Haven't you learned yet? Anything Ace says is either a lie, flat wrong, or just plain stupid.

_________________
BELIEVE NOTHING, no matter where you read it, or who has said it,
not even if I have said it, unless it agrees with your own reason
and your own common sense. - GAUTAMA BUDDHA
AceCombat
SpongeBob




PostPosted: Fri Sep 05, 2008 2:25 pm View user's profile Reply with quote Send private message

kiss my fat white ass bun! Very Happy Twisted Evil Evil or Very Mad

_________________
A United States Marine, is the last son-ova-bitch you ever want to piss off!!
When it has to be absolutely destroyed and eradicated of any and all enemy forces..... CALL THE MARINES!!!
JBOMB
DBB Cadet




PostPosted: Fri Sep 05, 2008 3:31 pm View user's profile Reply with quote Send private message

looking at that code again i see the "name = mymoviename"
(second to last line)


im pretty sure "mymoviename" is supposed to be "dbb_logo.swf"
can you also include that change?
JBOMB
DBB Cadet




PostPosted: Fri Sep 05, 2008 8:29 pm View user's profile Reply with quote Send private message

/me starts poking around where he shouldnt...

where does this embed code go in the phpbb?

Smile
Rook
DBB Staff




PostPosted: Sat Sep 06, 2008 10:58 am View user's profile Reply with quote Send private message

For me mousing over the logo changes the pointer as if it were a link but clicking does nothing.

_________________
"I too, am exercising restraint... !".-- Stresstest
Hattrick
Hog Whisperer




PostPosted: Sat Sep 06, 2008 12:44 pm View user's profile Reply with quote Send private message

works just fine for me.

_________________
I was born ok the first time!
wisdom comes with age. Sometimes age comes alone.
JBOMB
DBB Cadet




PostPosted: Sat Sep 06, 2008 4:05 pm View user's profile Reply with quote Send private message

Rook wrote:
For me mousing over the logo changes the pointer as if it were a link but clicking does nothing.


same..but i think the addition of that code should solve it...lets do this Smile
LotharBot
Hotshot




PostPosted: Sat Sep 06, 2008 4:15 pm View user's profile Reply with quote Send private message

Hattrick wrote:
works just fine for me.


Yep, me too.

Some people might need to force-reload the page.
JBOMB
DBB Cadet




PostPosted: Sat Sep 06, 2008 4:20 pm View user's profile Reply with quote Send private message

negative! Forget refreshing and forced reloads..its not an issue with the actual dbb_logo.swf (which i recently double checked for button errors)

it has everything to do with YOUR version of the flash player for your browser and the snippet of code that resides in the php embed that allows script access to the page!

In fact...for those of you that it still works for do me a favor..go update your flash and let us know if it still works.

so like i said..lets do this!

(a quick view source lets you know the embed code has not yet been changed)
AceCombat
SpongeBob




PostPosted: Sun Sep 07, 2008 8:31 am View user's profile Reply with quote Send private message

now bunny-bitch.... whos the liar? i told you it was working just fine for me! Razz


HEHE!! ya know i gotta keep my current relations and tensions up and running strong! Evil or Very Mad

_________________
A United States Marine, is the last son-ova-bitch you ever want to piss off!!
When it has to be absolutely destroyed and eradicated of any and all enemy forces..... CALL THE MARINES!!!
Pun
DBB Admin




PostPosted: Sun Sep 07, 2008 9:13 am View user's profile Reply with quote Send private message

JBOMB wrote:
negative! Forget refreshing and forced reloads..its not an issue with the actual dbb_logo.swf (which i recently double checked for button errors)

it has everything to do with YOUR version of the flash player for your browser and the snippet of code that resides in the php embed that allows script access to the page!

In fact...for those of you that it still works for do me a favor..go update your flash and let us know if it still works.

so like i said..lets do this!

(a quick view source lets you know the embed code has not yet been changed)


Okay! Okay! I'll look at it this afternoon.
AlphaDoG
porn 'n beans




PostPosted: Sun Sep 07, 2008 6:28 pm View user's profile Reply with quote Send private message

Thanks PUN
Pun
DBB Admin




PostPosted: Sun Sep 07, 2008 11:33 pm View user's profile Reply with quote Send private message

Okay. I made those two changes to the overallheader.tpl and this is what I got:



Any suggestions?
Pun
DBB Admin




PostPosted: Sun Sep 07, 2008 11:35 pm View user's profile Reply with quote Send private message

Code:
<object

classid="clsid:d27cdb6e-ae6d-11cf-96b8-

444553540000"codebase="http://download.macromedia.com/pub/shockwave/

cabs/flash/swflash.cab#version=6,0,40,0"width="430"

height="91"id="dbb_logo.swf"><param

name="movie"value="http://descentbb.com/flash/dbb_logo.swf" /><param

name="quality" value="high" /><param name="bgcolor" value="#ffffff" /><embed

src="http://descentbb.com/flash/dbb_logo.swf" allowScriptAccess="always"

quality="high" bgcolor="#ffffff"width="430" height="91"name="mymoviename"

align="" type="application/x-shockwave-

flash"pluginspage="http://www.macromedia.com/go/getflashplayer"></embed></ob

ject>
BUBBALOU
Insane!




PostPosted: Mon Sep 08, 2008 9:38 am View user's profile Reply with quote Send private message

does not work with firefox 3.0.1

but works fine with IE 7.0.5730.13

both are current/java/flash

if that helps

_________________
I seem to have a better workout dodging your stupidity than attempting to grasp the weight of your intelligence
JBOMB
DBB Cadet




PostPosted: Mon Sep 08, 2008 3:08 pm View user's profile Reply with quote Send private message

so wait pun...when you added the snippet it broke the whole deal? turned sht white like it was all scared?

i see the code "allow script access" code is not currently up..you pulled it i assume..

(im on aim) Smile
Pun
DBB Admin




PostPosted: Mon Sep 08, 2008 7:26 pm View user's profile Reply with quote Send private message

That's right.
JBOMB
DBB Cadet




PostPosted: Mon Sep 08, 2008 7:29 pm View user's profile Reply with quote Send private message

ok...heres what i did.

I used CS3 to embed the dbb logo onto its own page here: (thus updating all the embed code)

http://www.mediafishcreative.com/dbb.html

it works even from a different server. So..viewing the page source on the link i just provided there are a few things to be noticed..

The version of the flash player being called in the script. (9 vs 6)
The dbb_logo.swf being referenced in the proper areas.
The addition of some java script up top. Its function unknown to me..

My suggestion Pun is to look at the code there and use it for here (i have the flash correctly placed in its folder location to mirror the dbb)

I would first start with everthing in the <object> </object> and go from there. (leaving the java up top out of the equation at first)

Because this works on that link...id like to see if it works here. (sans the allow script access snippet because i dont have it on that link either)
Grendel
Ninja Admin




PostPosted: Mon Sep 08, 2008 7:40 pm View user's profile Reply with quote Send private message

You should link the logo to this ! Smile
JBOMB
DBB Cadet




PostPosted: Mon Sep 08, 2008 7:48 pm View user's profile Reply with quote Send private message

lol...no!

UPDATE:

i used the old embed code here:
http://www.mediafishcreative.com/dbb2.html

and the logo no longer links!

i think we have found the culprit johnny...

updated embed code lets do this!
JBOMB
DBB Cadet




PostPosted: Mon Sep 08, 2008 7:53 pm View user's profile Reply with quote Send private message

update update:

im confident this code takes care of business

Code:

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="430" height="91">
  <param name="movie" value="flash/dbb_logo.swf">
  <param name="quality" value="high">
  <embed src="flash/dbb_logo.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="430" height="91"></embed>
</object>




use as is..object to object
Foil
2*pi*r




PostPosted: Mon Sep 08, 2008 10:48 pm View user's profile Reply with quote Send private message

Now works for me. Thanks, J!

_________________
"You seem a decent fellow. I hate to kill you."
"You seem a decent fellow. I hate to die."
JBOMB
DBB Cadet




PostPosted: Mon Sep 08, 2008 10:55 pm View user's profile Reply with quote Send private message

heheh...not yet foil... Smile
Thorne
Ace




PostPosted: Tue Sep 09, 2008 7:21 am View user's profile Reply with quote Send private message

Never mind. I think you should have it pegged.

_________________
"Whatever your hand finds to do, do it with your might;
for there is no work or device or knowledge or wisdom in the grave where you are going."
BUBBALOU
Insane!




PostPosted: Tue Sep 09, 2008 1:16 pm View user's profile Reply with quote Send private message

working good in FF, now

where is the hot multi action banner

_________________
I seem to have a better workout dodging your stupidity than attempting to grasp the weight of your intelligence
JBOMB
DBB Cadet




PostPosted: Tue Sep 09, 2008 4:44 pm View user's profile Reply with quote Send private message

BUBBALOU wrote:
working good in FF, now

where is the hot multi action banner


negative...view source..nothing has been changed yet...
BUBBALOU
Insane!




PostPosted: Tue Sep 09, 2008 6:34 pm View user's profile Reply with quote Send private message

did this afternoon just 1 click, now it doesn't after i logged in with username....what are you guys doing.....

Don't make me USE IE............

_________________
I seem to have a better workout dodging your stupidity than attempting to grasp the weight of your intelligence
JBOMB
DBB Cadet




PostPosted: Tue Sep 09, 2008 8:27 pm View user's profile Reply with quote Send private message

super fixed!
Goto page 1, 2  Next
View previous topic :: View next topic  
All times are GMT - 6 Hours
Post new topic   Reply to topic
Jump to:  
   Descent BB Forum Index > Forum Support and Feedback > Ummm JBOMB

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Image hosting by postimage.org Powered by phpBB © 2001, 2005 phpBB Group